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Description

What the
HP 14565A
Will Do

The HP 14565A Device Characterization Software is an easy-
to-use graphical user interface for the HP 66300-series
Dynamic Measurement DC Sources. With it, you can:
ó Control output and measurement functions from a single

screen.
ó View an oscilloscope-like display of dynamic output

measurements.
ó Superimpose up to two stored waveforms on active

waveform data.
ó Get measurement details by zooming in on active

waveforms.
ó View calculated measurements based on active waveforms.
ó Save and recall waveform data.

What the
HP 14565A
Will Not Do

The HP 14565A Device Characterization Software does not:
ó Control instruments other than HP dc sources.
ó Provide drivers for other HP-IB instruments.
ó Operate with Windows 3.1.

System Requirements

PC ó  486DX66 (minimum)
ó  16 Mbytes RAM
ó  4 Mbytes of disk space

32-bit
Platforms

ó  Windows 98
ó  Windows 95
ó  Windows NT 4.0

Supported
I/O

ó  HP 82340B, HP 82341C, HP82341D, HP 82335B1

ó  National AT GP-IB/TNT, AT GP-IB/TNT PnP (Windows 95)
ó  RS-232
1The HP 82335B is only supported for Windows 95, provided you have either the
E2094F or E2094E I/O library.

Supported
Dc Source
Models

ó  HP 66311A
ó  HP 66312A
ó  HP 66332A
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Installing and Running the Software

NOTE: Before running the HP 14565A application, you must have installed and
connected your dc source to the PC using the appropriate interface
cable. If you are using an HP-IB/GP-IB interface, you must have the
appropriate card installed and configured on your PC. If you are using
an HP interface card, you must also have the appropriate 32-bit SICL
library drivers installed on your PC.

1. Place Disk #1 in the A: drive of your computer and run SETUP.EXE.

2. Follow the directions on the screen to install the software. The README.TXT
file contains product updates or corrections that are not documented in the
help file. Use any text editor to open and read this file.

3. To run the application, click on the Start button and select: Programs | HP
14565A DCS | HP 14565A Device Characterization Software.

Configuring the I/O

Make sure that the dc source is turned on. To configure the I/O, select the I/O
Configuration command in the Edit menu. This step is necessary to establish
communication with the dc source. The I/O configuration screen comes up
automatically if no dc source is configured.
Note that the serial port is much slower than the HP-IB interface.

If there seems to be no communication between the HP 14565A application and the
dc source, select Auto Detect to detect any dc sources connected to your PC. Also,
try resetting the I/O interface by clicking the reset button. This also resets the dc
source to its default settings.

NOTE: If you program the HP dc source from the front panel of the unit, you
will need to refresh or update the HP 14565A application. Go to the
View menu and select the Reread Instrument State command.
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Performing Basic Operations

The Main window appears when you first run the HP 14565A application. From
this window you can control the output of the dc source as well as view basic
output measurements.

To set the voltage and current levels:

ó Click in the field labeled Voltage Setting, type in the desired output voltage
and press Enter.

ó Enter a current limit value in the field labeled Current Setting.

To turn on the output:

ó Enable the dc source output by pressing the ON button.  If the message OVLD
appears in the display, set the Current Meas control to the Hi Range.

To make a measurement:

ó Click the A button to select current measurements; click the V button to select
voltage measurements.

ó Click the Measure button to make the measurement.

ó Adjust the time/div and amps/div fields to vary the sample rate and vertical
scale. Click Auto Scale to fit the display to the acquired waveform.

To display a sample waveform:

ó Select the Load Waveform command in the File menu, and then select
DemoWaveform1.txt.

ó Select Active Waveform in the Load Waveform Location dialog box. The
waveform should match the one shown in the above figure.
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Display Area

The display area displays the output measurement after the Measure button is
pressed. The following figure describes the various measurements displayed in the
window.

The values in the measurement area at the bottom of the display are calculated
from the all of the data that is captured in the display. If horizontal markers have
been set, measurements are calculated only from the data between the markers.
Refer to Performing Measurements on Waveforms.

Calculated measurements at the bottom of the display may not agree exactly with
values shown on the front panel of  the instrument if the sample rate of the display
differs significantly from the instrument’s front panel sample rate.

Making Triggered Measurements

Triggered measurements let you control when the measurement trigger will occur.
The following figure describes the various trigger controls.

NOTE: If you do not know where to set the trigger level, you can make a
measurement with  the trigger set to Auto Trig. Then view the
measurement to see where to place the trigger level. Set the trigger
controls and make another measurement.

ó Press the A button to select current measurements or press the V button to
select voltage measurements.

• Set the time/div control to a value that is appropriate for the load’s transient
timing.
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• Select a trigger setting. Choose from Pos Slope, Neg Slope, or Either Slope to
set up the triggered measurement.

• Adjust the Level slide control until the trigger level is at the point where the
trigger should occur. The trigger level is displayed as a red horizontal line on
the display.

NOTE: The trigger level cannot go negative. Set the trigger control to Auto
Trig to trigger negative waveforms.

• Use the Pre-Trigger control to show pre-trigger waveform information. When
this control is used, the trigger point will be displayed as a short vertical red
line on the bottom of the waveform display graph.

• To prevent signal noise from triggering a measurement, you can adjust the
Hysteresis slide control to create a hysteresis band around the trigger level.
The hysteresis band is shown in yellow. Triggers cannot occur inside the
hysteresis band.

• Use the Envelope control to more accurately average the High level of
multiple current pulses (refer to the online Help for more information).

• Press the Measure button to initiate the triggered measurement.

• The display should now show the voltage or current waveform starting at the
trigger level.

• Change the amps/div control to adjust the vertical scale or press the Auto
Scale button to maximize the displayed waveform size.
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Performing Measurements on Waveforms

Use the marker controls to make precise waveform measurements.

ó To view the horizontal and vertical markers, click on the marker buttons on
the toolbar. Use the mouse to position the marker.

To display
markers, click
on

You can also zoom in on a specific area of the waveform. Zooming in only rescales
the display, no calculations are performed in the zoom area.

ó To zoom in on a specific area on the display, use either the zoom in button on
the toolbar, use the mouse to draw a rectangle on the display.

ó To zoom out, use either the zoom out button or place the cursor in the display
area and right-click on the mouse. Then select Zoom Out.

To zoom,
either click on
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Placing a Waveform on the Display

Up to two reference waveforms can be shown on the display along with the
measured or active waveform. This is useful if you want to compare waveform
measurements to a “standard” or reference waveform to make a pass/fail
determination on the measurement. Waveforms are displayed in different colors,
which can be edited by selecting Edit/Preferences. Measurement calculations can
only be done on active waveforms, not reference waveforms.

ó Select the Load Waveform command in the File menu to load a waveform.

ó Enter the filename of the waveform in the Open dialog box. The default
location for waveforms is C:\ Program Files \ HP14565dcs.

ó Select Active Waveform in the Select Waveform Location dialog box only if
you want to perform measurements on the loaded waveform.

ó Use the Remove Waveform command in the File menu to remove a loaded
waveform from the display.

Printing and Saving Measurement Data

The HP 14565A application supports printing and print previewing of the display.
Use the Print Preview command in the File menu to preview the display. Use the
Print command to print the display to your default printer.

Use the Save Waveform command in the File menu to save the voltage or current
measurement data to an ASCII text file that you specify in the Save As dialog box.
All of the data points that comprise a waveform are logged in a 2-column
Time/Voltage or Time/Current format. The information can be imported into a
database or spreadsheet, or edited by a text editor. This is useful if you need to
create a reference waveform that you would normally not be able to create by just
taking a measurement.
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Advanced Measurement Settings

To configure output measurements, select the Measurement Settings command in
the Source menu.

Display Preferences

To configure display preferences, select the Preferences command in the Edit
menu.

Source Settings

To display the protection settings of the dc source that is presently being
controlled, select the Source Settings command in the Source menu.
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Sample Waveforms

Several sample waveforms are provided with the HP 14565A application. If you do
not have a dc source connected to your PC, you can still become familiar with the
application by trying out the various display functions using the sample waveforms.

DemoWaveform1.txt

This waveform is a single transmit current pulse from a cellular phone. It clearly
shows the location of the Max, High, Min, and Low measurement points.

DemoWaveform2.txt

This waveform is also a single transmit current pulse from a cellular phone. Its
main features are the multiple low-level signals. Note that the High and Low levels
of the waveform are based on the two portions of the measurement (out of a total of
1024 equally divided portions), that have the most high or low points - and that
include at least 1.25% of the total measurement points.

DemoWaveform3.txt

This waveform includes three transmit current pulses from a cellular phone. Note
that in this case, the High and Max values are the same. This is because no portion
of the measurement above the 50% point includes at least 1.25% of the total
measurement points.
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Warranty

This Hewlett-Packard software product is warranted against defects in materials and
workmanship for a period of 90 days from date of delivery. During the warranty period,
Hewlett-Packard Company will, at its option either repair or replace parts which prove to be
defective.

Hewlett-Packard makes no express or implied warranty of any kind, including, but not
limited to the implied warranties of merchantability or fitness for a particular purpose, with
regard to the program material contained herein. Hewlett-Packard shall not be liable for
incidental or consequential damages in connection with or arising out of the furnishing,
performance, or use of this software.

Use of the supplied manual and software is restricted to HP dc source products only. The
software is copyrighted and may not be copied except for archival purposes, to replace a
defective copy, or for program error verification. Hewlett-Packard warrants that this
software designed for use with a personal computer, will execute its programming
instructions when properly installed on that personal computer. Hewlett-Packard does not
warrant that the operation of the personal computer , software, or dc source will be
uninterrupted or error free.

Limitation of Warranty
The foregoing warranty shall not apply to defects resulting from: misuse, unauthorized
modification, operation or storage outside the environmental specifications for the product,
in-transit damage, improper maintenance, or defects resulting from use of non-HP software,
accessories, media, or such items not designed for use with the product.

Notice
This document contains proprietary information protected by copyright. All rights are
reserved.  No part of this document may be photocopied, reproduced, or translated into
another language without the prior consent of Hewlett-Packard Company. The information
contained in this document is subject to change without notice.

  Copyright 1998 Hewlett-Packard Co.

Windows is a registered trademark of Microsoft Corporation.

Manual part number 5962-8293       Printed in USA, September 1998
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